app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Sep 30, 2020 - 23:48 CEST
Investigating
Socket timeout, unable to connect to server
Posted Sep 30, 2020 - 23:48 CEST
This incident affected: Application.