app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Sep 14, 2020 - 11:04 CEST
Investigating
HTTP Server Error 503 Service Unavailable
Posted Sep 14, 2020 - 11:03 CEST
This incident affected: Application.