app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 08:26 CEST
Investigating
Socket timeout, unable to connect to server
Posted Apr 01, 2020 - 08:25 CEST
This incident affected: Portal.