app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 7 months ago. Jan 30, 2019 - 00:27 CET
Investigating
Invalid HTTP response received from server
Posted 7 months ago. Jan 30, 2019 - 00:23 CET
This incident affected: Application.