app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 30, 2019 - 10:10 CET
Investigating
Socket timeout, unable to connect to server
Posted 3 months ago. Jan 30, 2019 - 10:09 CET
This incident affected: Application.