app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 20 days ago. Jul 29, 2019 - 16:14 CEST
Investigating
Invalid HTTP response received from server
Posted 20 days ago. Jul 29, 2019 - 16:06 CEST
This incident affected: Application.