app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 3 months ago. Jan 30, 2019 - 07:52 CET
Investigating
Invalid HTTP response received from server
Posted 3 months ago. Jan 30, 2019 - 07:49 CET
This incident affected: Application.