app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 9 days ago. Oct 07, 2019 - 22:21 CEST
Investigating
Invalid HTTP response received from server
Posted 9 days ago. Oct 07, 2019 - 22:20 CEST
This incident affected: Application.