app-wallee.com is not reachable
Incident Report for Wallee Statuspage
Resolved
This incident has been resolved.
Posted Dec 09, 2020 - 22:27 CET
Investigating
Invalid HTTP response received from server
Posted Dec 09, 2020 - 22:23 CET