app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 17 days ago. Nov 27, 2018 - 23:00 CET
Investigating
Invalid HTTP response received from server
Posted 17 days ago. Nov 27, 2018 - 22:44 CET
This incident affected: Application.