app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 8 months ago. Nov 01, 2018 - 14:03 CET
Investigating
Invalid HTTP response received from server
Posted 8 months ago. Nov 01, 2018 - 14:00 CET
This incident affected: Application.