app-wallee.com is not reachable
Incident Report for Wallee Statuspage
Resolved
This incident has been resolved.
Posted Mar 16, 2021 - 17:08 CET
Investigating
Socket timeout, unable to connect to server
Posted Mar 16, 2021 - 17:07 CET