app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Aug 20, 2020 - 14:18 CEST
Investigating
Invalid HTTP response received from server
Posted Aug 20, 2020 - 14:16 CEST
This incident affected: Portal.