app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 17 days ago. Apr 08, 2019 - 12:13 CEST
Investigating
Invalid HTTP response received from server
Posted 17 days ago. Apr 08, 2019 - 12:09 CEST
This incident affected: Application.