app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 5 months ago. Jan 30, 2019 - 09:32 CET
Investigating
Invalid HTTP response received from server
Posted 5 months ago. Jan 30, 2019 - 09:31 CET
This incident affected: Application.