app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 3 months ago. Jun 22, 2019 - 00:40 CEST
Investigating
Socket timeout, unable to connect to server
Posted 3 months ago. Jun 22, 2019 - 00:37 CEST
This incident affected: Application.