app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 11 days ago. Dec 03, 2018 - 21:39 CET
Investigating
Invalid HTTP response received from server
Posted 11 days ago. Dec 03, 2018 - 21:35 CET
This incident affected: Application.