app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Oct 15, 2020 - 05:08 CEST
Investigating
Cannot make SSL connection - Error on receive
Posted Oct 15, 2020 - 04:46 CEST
This incident affected: Application.