app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 4 months ago. Jan 30, 2019 - 11:01 CET
Investigating
Invalid HTTP response received from server
Posted 4 months ago. Jan 30, 2019 - 10:58 CET
This incident affected: Application.