app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Nov 27, 2019 - 04:08 CET
Investigating
Invalid HTTP response received from server
Posted Nov 27, 2019 - 04:07 CET
This incident affected: Application.