app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Jan 09, 2020 - 20:49 CET
Investigating
Invalid HTTP response received from server
Posted Jan 09, 2020 - 20:46 CET
This incident affected: Application.