app-wallee.com is not reachable
Incident Report for Wallee Statuspage
Resolved
This incident has been resolved.
Posted Jul 23, 2022 - 02:27 CEST
Investigating
Invalid HTTP response received from server
Posted Jul 23, 2022 - 02:26 CEST