app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Oct 04, 2020 - 16:34 CEST
Investigating
HTTP Server Error 503 Service Unavailable
Posted Oct 04, 2020 - 16:33 CEST
This incident affected: Application.