app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Aug 07, 2020 - 09:43 CEST
Investigating
Invalid HTTP response received from server
Posted Aug 07, 2020 - 09:41 CEST
This incident affected: Portal.