app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Feb 12, 2020 - 07:30 CET
Investigating
Invalid HTTP response received from server
Posted Feb 12, 2020 - 07:27 CET
This incident affected: Application.