app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 5 days ago. Sep 12, 2019 - 09:26 CEST
Investigating
Socket timeout, unable to connect to server
Posted 5 days ago. Sep 12, 2019 - 09:23 CEST
This incident affected: Application.