app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted about 2 months ago. Nov 21, 2018 - 07:42 CET
Investigating
Invalid HTTP response received from server
Posted about 2 months ago. Nov 21, 2018 - 07:40 CET
This incident affected: Application.