app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 4 months ago. Nov 21, 2018 - 09:08 CET
Investigating
Invalid HTTP response received from server
Posted 4 months ago. Nov 21, 2018 - 09:07 CET
This incident affected: Application.