app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 23:23 CEST
Investigating
Non-recoverable failure in name resolution
Posted Jul 17, 2020 - 23:22 CEST
This incident affected: Portal.