app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 13, 2019 - 15:19 CET
Investigating
Socket timeout, unable to connect to server
Posted 6 months ago. Feb 13, 2019 - 15:18 CET
This incident affected: Application.