app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Nov 10, 2020 - 09:37 CET
Investigating
HTTP Server Error 503 Service Unavailable
Posted Nov 10, 2020 - 09:36 CET
This incident affected: Portal.