app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 3 months ago. Dec 17, 2018 - 05:09 CET
Investigating
Invalid HTTP response received from server
Posted 3 months ago. Dec 17, 2018 - 05:08 CET
This incident affected: Application.