app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 29, 2019 - 18:22 CEST
Investigating
Invalid HTTP response received from server
Posted 3 months ago. Jul 29, 2019 - 18:20 CEST
This incident affected: Application.