app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Dec 04, 2019 - 12:02 CET
Investigating
Invalid HTTP response received from server
Posted Dec 04, 2019 - 11:56 CET
This incident affected: Application.