app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Jul 20, 2020 - 07:15 CEST
Investigating
Socket timeout, unable to connect to server
Posted Jul 20, 2020 - 06:53 CEST
This incident affected: Portal.