app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Sep 29, 2020 - 13:11 CEST
Investigating
Socket timeout, unable to connect to server
Posted Sep 29, 2020 - 13:08 CEST
This incident affected: Application.