app-wallee.com is not reachable
Incident Report for Status of wallee
Resolved
This incident has been resolved.
Posted Jul 24, 2020 - 11:58 CEST
Investigating
Socket timeout, unable to connect to server
Posted Jul 24, 2020 - 11:57 CEST
This incident affected: Application.